آسیب پذیری ماژول ap_get_basic_auth_pw در Appache

03 تیر 1396
نویسنده :  

استفاده از ماژول جانبی آسیب پذیر" ap_get_basic_auth_pw" در Apache HTTPD در برخی موراد باعث می شود احراز هویت bypassed شود. برای رفع این آسیب پذیری از ماژول ap_get_basic_auth_componentsکه در نسخه های Appache 2.2.33  و 2.4.26 Appache قرار داده شده است استفاده شود. این ماژول پس از اتصال کاربر، آن را احراز هویت می کند و یا بلافاصله پس از پاسخ خطا درخواست را متوقف می کند تا از تصحیح اشتباه درخواست فعلی به دلیل امنیت بالا و جلوگیری از حملات احتمالی جلوگیری شود.

 

References :

  • CEV-2017-3167

Solution :

  • apache-httpd-upgrade-2_2_33

  • https://www.apache.org/dist/httpd/patches/apply_to_2.2.32/CVE-2017-3167.patch.

 

1569 تعداد بازدید
علی سالم پناه

متخصص شبکه و امنیت شبکه

مهندسین شبکه افزار سایان

  • اهواز - خیابان وهابی خ 19 شرقی پلاک 20
  • 061-33386011-13
  • 061-33374556
  • spambots

پیشنهادات خود را با ما در میان بگذارید

  ایمیل ارسال نشد   ایمیل با موفقیت ارسال شد